Item Deprecation - Playstation Belgium E-Gift Card €20

Incident Report for rewards

Investigating

We are currently investigating this issue.
Posted Mar 31, 2025 - 12:58 PDT

Identified

Effective immediately, Playstation Belgium E-Gift Card €20 is no longer available through Tango.

The affected UTID is: U702029
Posted Mar 26, 2025 - 07:04 PDT
This incident affects: Europe (EUR (Belgium)).