Item Deprecation - Kigso Games Gift Card €10
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 10:47 PST
Identified
Effective immediately, [item] is no longer available through Tango.

The affected UTID(s) are: U754394
Posted Nov 07, 2024 - 07:58 PST
This incident affected: Europe (EUR (Belgium), EUR (Finland), EUR (France), EUR (Germany), EUR (Ireland), EUR (Italy), EUR (Netherlands), EUR (Portugal), EUR (Spain), EUR (Austria), EUR (Slovakia), EUR (Slovenia), EUR (Greece), EUR (Latvia), EUR (Estonia), EUR (Lithuania), EUR (Luxembourg)).