Item Outage - Ty Inc eGift

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update:
https://rewardstatus.tangocard.com/incidents/vmmrl148m6lz
Posted Nov 12, 2025 - 10:12 PST

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U475422
Posted Oct 31, 2025 - 14:14 PDT
This incident affected: Americas (USD).