Brand Outage - Biedronka Poland
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 10:56 PST
Investigating
This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U388082, U784439, & U532186
Posted Jan 10, 2025 - 12:28 PST
This incident affected: Europe (PLN).