Item Deprecation - Belk eGift Card $10 - 5/24/2021
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jun 24, 2021 - 11:07 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 24, 2021 - 15:13 PDT
Identified
Effective immediately, Belk eGift Card $10 is no longer available through Tango Card.

The affected UTID is: U769115
Posted May 12, 2021 - 08:54 PDT
This incident affected: Americas (USD).