Item Outage - Eataly Italy
Incident Report for rewards
Resolved
This outage has been resolved.
Posted Oct 25, 2021 - 13:23 PDT
Identified
This item is currently unavailable. We will post an update when this item is available again.

The affected UTIDs are: U744988, U649851, U878497, U426256, U552526.
Posted Jul 26, 2021 - 09:07 PDT
This incident affected: Europe (EUR (Italy)).