Item Outage - MX ONLY - Uber MX Gift Card $150 - 5/1/2021
Incident Report for rewards
Resolved
This outage has been resolved.
Posted May 03, 2021 - 10:13 PDT
Identified
MX ONLY - Uber MX Gift Card $150 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U706438
Posted May 01, 2021 - 18:16 PDT
This incident affected: Americas (MXN).