Item Outage - Adidas Finland €50 eGift Card
Incident Report for rewards
Update
We are continuing to investigate this issue.
Posted Jan 14, 2025 - 06:18 PST
Investigating
This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U575225
Posted Jan 13, 2025 - 08:31 PST
This incident affects: Europe (EUR (Finland)).