Item Deprecation - Spotify Latvia Gift Card €7

Incident Report for rewards

Resolved

This item has been officially deprecated and is no longer available through Tango.
Posted May 06, 2025 - 07:43 PDT

Identified

Effective immediately, Spotify Latvia €7 is no longer available through Tango.

The affected UTID(s) are: U117532
Posted Apr 09, 2025 - 12:15 PDT
This incident affected: Europe (EUR (Latvia)).