Item Outage - Spotify Lithuania Gift Card €21

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's a link to the most recent deprecation status: https://rewardstatus.tangocard.com/incidents/0nf1cwqkbbgz
Posted Apr 22, 2025 - 14:20 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U912046
Posted Mar 17, 2025 - 08:40 PDT
This incident affected: Europe (EUR (Lithuania)).