Item Outage - Lulu Hypermarket Gift Card Malaysia RM25

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update:
https://rewardstatus.tangocard.com/incidents/1lfmjlgdkhs2
Posted May 19, 2025 - 13:49 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U969301
Posted May 19, 2025 - 11:19 PDT
This incident affected: Asia (MYR).