Catalog Change Notice - Mango Belgium

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 09:29 PDT

Identified

Effective immediately, Mango Belgium will switch from a variable item to fixed denominations. The change is as follows:

No longer available:

U991393: Min: €10 - Max: €100

New UTIDs:

U500272: €10
U995472: €20
U463270: €30
U377085: €50
U591761: €100
Posted Feb 20, 2025 - 15:57 PST
This incident affected: Europe (EUR (Belgium)).