Item Deprecation - Steam Wallet Code €10, €50, €100

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 11:10 PST

Identified

Effective immediately, Steam Wallet Code €10, €50, and €100 are no longer available through Tango.

The affected UTID(s) are:
U656778
U270672
U979523
Posted Jan 24, 2025 - 09:32 PST
This incident affected: Europe (EUR (Belgium), EUR (Finland), EUR (France), EUR (Germany), EUR (Ireland), EUR (Italy), EUR (Netherlands), EUR (Portugal), EUR (Spain), EUR (Austria), EUR (Slovakia), EUR (Slovenia), EUR (Greece), EUR (Latvia), EUR (Montenegro), EUR (Estonia), EUR (Lithuania), EUR (Luxembourg)).