Item Outage -TripGift eGift Card €100

Incident Report for rewards

Resolved

This incident has been resolved.
Posted 5 days ago. Mar 31, 2025 - 11:19 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U365683
Posted 15 days ago. Mar 21, 2025 - 06:35 PDT
This incident affected: Europe (EUR (Belgium), EUR (Finland), EUR (France), EUR (Germany), EUR (Ireland), EUR (Italy), EUR (Netherlands), EUR (Portugal), EUR (Spain), EUR (Austria), EUR (Slovakia), EUR (Slovenia), EUR (Greece), EUR (Latvia), EUR (Montenegro), EUR (Estonia), EUR (Lithuania), EUR (Luxembourg)).