EGY Rewards Deprecation
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 05, 2021 - 14:23 PDT
Monitoring
Effective today, July 19th, EGP Rewards and RL Egypt will no longer be available through Tango Card.
Posted Jul 19, 2021 - 16:19 PDT