Item Outage - Myntra Gift Card India ₹1,000

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update: https://rewardstatus.tangocard.com/incidents/mm5t8677lm12
Posted Jun 03, 2025 - 10:28 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U885066
Posted May 15, 2025 - 14:13 PDT
This incident affected: Asia (INR).