Item Outage - Pepe Ganga Tarjeta de Obsequio Electrónica $50,000

Incident Report for rewards

Resolved

This item will no longer be available from Tango as of 04/24/2025 and the incident has been closed. Here's the link to the most recent deprecation status: https://rewardstatus.tangocard.com/incidents/7gg22mppg8mf
Posted Apr 17, 2025 - 15:08 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTID are: U454882
Posted Oct 30, 2024 - 10:02 PDT
This incident affected: Americas (COP).