Brand Outage - Baskin Robbins South Korea

Incident Report for rewards

Update

We are continuing to investigate this issue.
Posted Mar 19, 2025 - 09:42 PDT

Update

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U935361, U839487, U969199, U705526, & U552044
Posted Mar 13, 2025 - 14:11 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U839487, U969199, & U705526
Posted Mar 04, 2025 - 06:48 PST
This incident affects: Asia (KRW).