Item Outage - Bath & Body Works eGift Card
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jun 24, 2021 - 10:58 PDT
Identified
This brand is temporarily unavailable. We will post an update when this becomes available again.

The affected UTID is U728067
Posted Jun 21, 2021 - 11:40 PDT
This incident affected: Americas (USD).