Item Denomination Change - Atom Tickets eGift Card - 12/11/2020
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 14:23 PST
Identified
Effective today, the minimum denomination for Atom Tickets eGift Cards has changed from $0.01 to $10 USD.
This change has been causing some order failures recently.
Please ensure all future Atom Tickets eGift Card orders comply with the updated variable range of $10 - $1,500 USD.

The affected UTID is: U535252
Posted Dec 11, 2020 - 14:14 PST
This incident affected: Americas (USD).