Elevated Errors - Bed Bath & Beyond® eGift Card
Incident Report for rewards
Resolved
This incident has been resolved.
Posted May 08, 2021 - 20:19 PDT
Identified
We are experiencing elevated errors for orders of Bed Bath & Beyond® eGift Card. We are monitoring this situation, and will update this incident when resolved.

The affected UTID is U186495
Posted May 06, 2021 - 11:12 PDT
This incident affected: Americas (USD).