Brand Outage - Ripley Tarjeta de Regalo Chile
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jan 06, 2025 - 06:26 PST
Investigating
This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U980224, U791699, & U618482
Posted Dec 18, 2024 - 08:12 PST
This incident affected: Americas (CLP).