Brand Outage - Reliance Retail Gift Card India

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update: https://rewardstatus.tangocard.com/incidents/n5yym133gj4d
Posted Jun 10, 2025 - 08:02 PDT

Identified

This brand is currently out of stock. We will post an update when it is available.

The affected UTID is: U692084, U754342, and U962575
Posted May 29, 2025 - 07:57 PDT
This incident affected: Asia (INR).