Item Outage - foodpanda.pk 2000 ₨ تحفہ والا کارڈ

Incident Report for rewards

Resolved

This item is no longer available.
Posted Feb 25, 2025 - 13:55 PST

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U413656
Posted Jun 14, 2024 - 07:13 PDT
This incident affected: Asia (PKR).