Brand Deprecation - JCB PREMO DIGITAL Japan

Incident Report for rewards

Resolved

This brand has been officially deprecated and is no longer available through Tango.
Posted Apr 28, 2025 - 07:34 PDT

Identified

Effective immediately, JCB PREMO DIGITAL is no longer available through Tango.

The affected UTID(s) are: U098096 and U634335
Posted Apr 04, 2025 - 05:50 PDT
This incident affected: Asia (JPY).