Item Outage - Amazon Pay Gift Card India ₹1000
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 10:59 PDT
Update
We are continuing to investigate this issue.
Posted Jun 08, 2021 - 17:47 PDT
Investigating
Amazon Pay Gift Card India ₹1000 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U705529
Posted Jun 08, 2021 - 17:47 PDT
This incident affected: Asia (INR).