Item Outage - Amazon Gift Card Turkey ₺250 and ₺500

Incident Report for rewards

Resolved

This item is now back in stock and available for ordering.
Posted Apr 15, 2025 - 06:18 PDT

Identified

These items are currently out of stock. We will post an update when it is available.

The affected UTIDs are: U506597 and U377803
Posted Apr 14, 2025 - 07:51 PDT
This incident affected: Middle East (TRY).