Brand Outage - Falabella Tarjeta de Regalo Chile
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 10:11 PST
Investigating
This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are:

U707036
U547964
Posted Oct 29, 2024 - 09:52 PDT
This incident affected: Americas (CLP).