Partial Brand Outage - JYSK Finland

Incident Report for rewards

Resolved

This brand is now back in stock and available for ordering.
Posted Apr 29, 2026 - 07:01 PDT

Identified

This brand is partially currently out of stock. We will post an update when it is available.

The affected UTIDs are:

U437190, U455169, U930494, U117210, U490605, and U237870
Posted Apr 27, 2026 - 10:10 PDT
This incident affected: Europe (EUR (Finland)).