Item Outage - ANSWEAR Karta podarunkowa eGift zł 50

Incident Report for rewards

Resolved

This item has been officially deprecated due to brand level issues and is no longer available through Tango.
Posted Sep 24, 2025 - 13:48 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U755649
Posted Sep 12, 2025 - 06:41 PDT
This incident affected: Europe (PLN).