Item Outage - PVR Inox Cinemas Gift Card India ₹100

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update: https://rewardstatus.tangocard.com/incidents/tw0bqqp3hjxc
Posted May 09, 2025 - 07:47 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U553602
Posted Apr 23, 2025 - 07:06 PDT
This incident affected: Asia (INR).