Brand Deprecation - Kigso Games

Incident Report for rewards

Update

U451086 (Kigso Games Gift Card £5), U119568 (Kigso Games Gift Card £10), and U105731 (Kigso Games Gift Card €5) are no longer available through Tango.
Posted Apr 29, 2024 - 11:43 PDT

Identified

Once inventory runs out, Kigso Games will no longer be available through Tango.

The affected UTID(s) are: U105731, U673834, U994379, U412922, U451086, U880770, U119568, U220161, U754394, U832539, U313196, U697356
Posted Apr 04, 2024 - 14:17 PDT
This incident affects: Americas (CAD, USD) and Europe (EUR (Belgium), EUR (Finland), EUR (France), EUR (Germany), EUR (Ireland), EUR (Italy), EUR (Netherlands), EUR (Portugal), EUR (Spain), GBP, EUR (Austria), EUR (Slovakia), EUR (Slovenia), EUR (Greece), EUR (Latvia), EUR (Croatia), EUR (Montenegro), EUR (Estonia), EUR (Lithuania), EUR (Luxembourg)).