Brand Deprecation - Jo-Ann Fabric and Craft Stores®

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 08:52 PST

Identified

Effective immediately, Jo-Ann Fabric and Craft Stores® is no longer available through Tango.

The affected UTID(s) are: U89295 & U400371
Posted Jan 16, 2025 - 11:28 PST
This incident affected: Americas (USD).