Catalog Change Notice - Yelmo Spain

Incident Report for rewards

Resolved

This change is now live. The updated denomination range/ changes are reflected in the catalog.
Posted Jul 02, 2025 - 07:57 PDT

Identified

Effective immediately, Yelmo Spain has a new denomination. The change is as follows:

No longer available:

U612332: €9 EUR

New denomination and UTID:

U013350: €11.50 EUR
Posted Jun 09, 2025 - 08:37 PDT
This incident affected: Europe (EUR (Spain)).