Brand Outage - Made In Cookware Gift Card $50 & $100

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 06:52 PST

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U666527 & U964845
Posted Jan 06, 2026 - 06:41 PST
This incident affected: Americas (USD).