Brand Outage - Lotus Malaysia

Incident Report for rewards

Resolved

This brand is now back in stock and available for ordering.
Posted Oct 24, 2025 - 08:58 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U687797, U930427, and U259092
Posted Oct 14, 2025 - 06:39 PDT
This incident affected: Asia (MYR).