Catalog Change Notice - Starbucks South Korea
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Sep 16, 2024 - 09:35 PDT
Identified
New denominations have been added for Starbucks South Korea. There is no update on when the old items will be available again.

New Available Items:
Starbucks South Korea Gift Card ₩10,000 - U904682
Starbucks South Korea Gift Card ₩20,000 - U703826
Starbucks South Korea Gift Card ₩30,000 - U194735
Starbucks South Korea Gift Card ₩50,000 - U293509

Unavailable Items:
Starbucks South Korea Gift Card ₩4500 - U732369
Starbucks South Korea Gift Card ₩4900 - U494258
Starbucks South Korea Gift Card ₩5000 - U405488
Starbucks South Korea Gift Card ₩5900 - U751970
Posted Aug 16, 2024 - 11:16 PDT
This incident affected: Asia (KRW).