Inactive Item - Sling TV eGift Cards - 10/27/2020
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 09:48 PST
Identified
Sling TV eGift Cards are currently unavailable and have been set to inactive in our system until further notice.

The affected UTIDs are:
U378833
U371046
U878197
Posted Oct 27, 2020 - 16:45 PDT
This incident affected: Americas (USD).