Brand Deprecation - Spotify Latvia

Incident Report for rewards

Resolved

This brand has been officially deprecated and is no longer available through Tango.
Posted Aug 26, 2025 - 07:13 PDT

Identified

Effective immediately, Spotify Latvia is no longer available through Tango.

The affected UTID(s) are: U243194, U788140
Posted Jul 31, 2025 - 13:06 PDT
This incident affected: Europe (EUR (Latvia)).