Item Outage -Made In Cookware Gift Card $50

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 12:17 PST

Update

We are continuing to work on a fix for this issue.
Posted Dec 03, 2025 - 12:16 PST

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U666527
Posted Dec 03, 2025 - 07:25 PST
This incident affected: Americas (USD).