Item Deprecation - Submarino.com Virtual Gift Card R$20
Incident Report for rewards
Resolved
This incident has been resolved.
Posted 4 months ago. Oct 04, 2024 - 14:17 PDT
Update
Effective immediately, [item] is no longer available through Tango.

The affected UTID(s) are: U774518
Posted 5 months ago. Sep 04, 2024 - 07:29 PDT
Identified
This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U774518
Posted 5 months ago. Sep 03, 2024 - 06:38 PDT
This incident affected: Americas (BRL).