Increased Errors - Multiple PHP Brands

Incident Report for rewards

Resolved

These items are now back in stock and available for ordering.
Posted Jul 31, 2026 - 07:11 PDT

Investigating

We are experiencing an increase in errors with multiple brands orders. The issue is currently being investigated.

The affected brands are:

Fully Booked Philippines
Grab Philippines
Razer Gold Philippines
Chris Sports Philippines
Grabmart Philippines
G-Cash Philippines
Rustans Philippines
Posted Jul 29, 2026 - 15:20 PDT
This incident affected: Asia (PHP).