Brand Outage - Amazon Pay Gift Card India

Incident Report for rewards

Resolved

This brand is now back in stock and available for ordering.
Posted May 06, 2025 - 13:13 PDT

Identified

This brand and items are currently out of stock. We will post an update when they are available.

The affected UTIDs are: U840890, U574083, U705529, U478645, U481200, U128141, U165089, U884558, U883093, U738315
Posted May 06, 2025 - 10:57 PDT
This incident affected: Asia (INR).