Brand Deprecation - Lulu Hypermarket Indonesia Gift Card

Incident Report for rewards

Update

Effective immediately, Lulu Hypermarket Indonesia is no longer available through Tango.

The affected UTID(s) are: U008535, U802339, U839905
Posted Mar 21, 2025 - 06:03 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is:
U802339
Posted Mar 17, 2025 - 09:29 PDT
This incident affects: Asia (IDR).