Item Outage - Cineworld eGift Voucher £20 - 4/11/2021
Incident Report for rewards
Resolved
This outage has been resolved.
Posted Apr 23, 2021 - 10:30 PDT
Identified
Cineworld eGift Voucher £20 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U195617
Posted Apr 11, 2021 - 14:06 PDT
This incident affected: Europe (GBP).