Brand Outage - Farmers eGift Card

Incident Report for rewards

Update

We are continuing to work on a fix for this issue.
Posted Mar 31, 2025 - 08:11 PDT

Identified

This brand is currently out of stock. We will post an update when it is available.

The affected UTIDs are: U388651 and U088315
Posted Mar 28, 2025 - 07:13 PDT
This incident affects: Oceania (NZD).