Item Outage - Virtual Prepaid Visa® EUR

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 09:56 PST

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U793885
Posted Feb 19, 2025 - 17:14 PST
This incident affected: Europe (EUR (Belgium), EUR (Finland), EUR (France), EUR (Germany), EUR (Ireland), EUR (Italy), EUR (Netherlands), EUR (Portugal), EUR (Spain), EUR (Austria), EUR (Slovakia), EUR (Slovenia), EUR (Greece), EUR (Latvia), EUR (Croatia), EUR (Montenegro), EUR (Estonia), EUR (Lithuania), EUR (Luxembourg)).