Item Outage - TripGift eGift Card €25

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 11:18 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U947970
Posted Mar 28, 2025 - 13:42 PDT
This incident affected: Europe (EUR (Belgium), EUR (Finland), EUR (France), EUR (Germany), EUR (Ireland), EUR (Italy), EUR (Netherlands), EUR (Portugal), EUR (Spain), EUR (Austria), EUR (Slovakia), EUR (Slovenia), EUR (Greece), EUR (Latvia), EUR (Estonia), EUR (Lithuania), EUR (Luxembourg)).