Item Outage - Gymgrossisten Gift Card Sweden 700kr

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update:
https://rewardstatus.tangocard.com/incidents/vnmy0c6k8csp
Posted May 13, 2025 - 13:03 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U865753
Posted Apr 28, 2025 - 10:40 PDT
This incident affected: Europe (SEK).