Brand Outage - SOGO Taiwan
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 08:15 PST
Update
We are continuing to work on a fix for this issue.
Posted Oct 23, 2024 - 09:58 PDT
Identified
This brand is currently out of stock. We will post an update when it is available.

The affected UTID's are: U150223, U180400, U456994, U638384
Posted Oct 18, 2024 - 07:55 PDT
This incident affected: Asia (TWD).